LoLa – Nalagalnik za lokalni PCX

Komplet za prenos programske opreme za lokalni PCX Alcatel-Lucent

Orodje za prenos programske opreme za Alcatel-Lucent OmniPCX Office Rich Communication Edition.

Zahteve

Osebni računalnik z 233-MHz procesorjem Pentium/AMD in najmanj 256 MB pomnilnika RAM

Microsoft Windows NT, Windows XP, Windows 2000, Windows 7 32/64 bit, Windows 8 32/64 bit (podprto od različice Lola 400/9.1), Windows 8.1 32/64 bit (podprto od različice Lola 400/12.1) ali Windows 2012 Server 64 bit (podprto od različice Lola 400/9.1)

V omrežnih lastnostih mora biti nameščena in izbrana možnost "»Files and Printer for the Network Microsoft (Datoteke in tiskalnik za omrežje Microsoft)«".

Internet Explorer >5.0 SP1

Nameščena kartica Ethernet

Ethernetni kabel za visokohitrostno podatkovno komunikacijo: ena ravna/navzkrižna zvita parica 10BaseT

Namestitveni nosilec podatkov s kompletom za prenos programske opreme za lokalni PCX Alcatel-Lucent, na katerem so strežniški programi LoLa, BOOTP in TFTP

Nosilci podatkov s paketom programske opreme, ki ga je treba prenesti na zadevno tablo

Imenik "DownloadingItems" programske opreme LoLa– pot je npr.
C:\Program Files\PCXTools\LoLa\LoLa400_Rx.x\DownloadingItems –
mora imeti podeljene vse pravice za program "LoLa400_Rx.x" in za vse "uporabnike". Pravice morajo biti nastavljene tako, da lahko vsi berejo in izvajajo datoteke.

Pravice za imenik, v katerem je shranjena varnostna kopija datoteke (za namene selitve – tj. posodobitve programske opreme), morajo biti nastavljene tako, da lahko vsi berejo in izvajajo datoteke.

Pravice za imenik tftpboot poti LoLa–, kjer je bila nameščena programska oprema LoLa, npr.
C:\Program Files\PCXTools\lola\LoLa400_Rx.x\tftpboot –
morajo biti nastavljene tako, da lahko vsi berejo in izvajajo datoteke.

Razpoložljiv prostor na disku mora biti večji od prostora, ki ga zavzemajo datoteke z varnostnimi kopijami.

V računalniku ne sme biti nameščena nobena druga različica programa LoLa.

Če uporabljate UAC (Nadzor uporabniškega računa – User Account Control), morate program LOLA pognati kot skrbnik.

Namestitev paketa LoLa

Pred namestitvijo paketa LoLa:

Preverite, ali omrežje deluje (glejte Odpravljanje težav).

Odstranite morebitne starejše različice paketa LoLa.

OPOMBA: Pred namestitvijo nove različice paketa LoLa je obvezna odstranitev stare.

Prvi korak je, da z enim od teh postopkov namestite programsko opremo z namestitvenih nosilcev podatkov:

Zaženite program, ki se sam raztegne, imenovan lola400_<različica>.exe (kjer je <različica> različica tega paketa). Prilagodite in potrdite nastavitve naslednjega okna programa za samoekstrahiranje s klikom na Unzip. Postopek se začne, ko se ekstrahira glavna namestitvena datoteka.

Če je paket že ekstrahiran, zaženite program setup.exe, ki pokliče glavni namestitveni postopek.

Glavni namestitveni postopek je razdeljen na tri korake:

LoLa– Namestitev v strežniku

Program strežnika BOOTP (tiha namestitev)

Program strežnika TFTP (tiha namestitev)

OPOMBA: Ta tri orodja so obvezna za prenos programske opreme table; če katerega od njih ni, prenos ne bo uspel.

Prvi postopek namestitve je preverjanje sistemskih zahtev. Nato sta na vrsti dva potrditvena postopka: potrdite mesti poti namestitve in mape programa. Po potrditvi se namestijo programske datoteke in posodobi sistem. Nato se drug za drugim zaženeta postopka tihe namestitve strežnikov BOOTP in TFTP. Ko je namestitev končana, se lahko samodejno zažene paket LoLa.

Konfiguracija

Strežnik LoLa

Če je v računalniku vklopljen požarni zid, ga izklopite.

Izklop časovnih omejitev:

  1. V registru pojdite na (x.x je številka izdaje):
    HKEY_CURRENT_USER\Software\PCXTools\LoLa400_Rx.x\LoLa\Config

  2. Nastavite vrednost UseTimeouts na 0

Če uporabljate dva omrežna vmesnika:

  1. V registru pojdite na:
    HKEY_CURRENT_USER\Software\PCXTools\LoLa400_Rx.x\LoLa\Config

  2. IpAddress: vnesite IP naslov omrežnega vmesnika računalnika, priključenega na OmniPCX Office.

  3. V primeru selitve s konfiguracije s CoCPU: COCPU_IP: COCPU_IP: vnesite IP naslov omrežnega vmesnika računalnika +2.
    IpAddress = 172.25.52.36, COCPU_IP = 172.25.52.38.

Strežnik BOOTP

Konfiguracija ni potrebna.

Strežnik TFTP

Konfiguracija ni potrebna.

Prenos programske opreme

Postopek

Prepričajte se, da je programska oprema, ki jo želite namestiti, na voljo v računalniku (na trdem disku ali CD-ROM-u) ali v omrežju (upoštevajte, da slaba kakovost omrežja lahko prepreči obremenitev procesorja).

  1. Pritisnite majhen gumb na sprednji strani plošče s procesorjem, da jo zaustavite.

  2. Počakajte, da začne LED na procesorju neprekinjeno svetiti, in odstranite ploščo iz platforme PBX.

  3. Iztaknite ploščo s procesorjem in nastavite stikalo DIP ali mostiček (odvisno od tipa procesorja) v položaj za način delovanja LoLa.

    Položaj stikala DIP za delovanje v načinu LoLa na procesorski plošči Aspen (CPU-1/2/3/4):

    Položaj stikala DIP za delovanje v načinu LoLa na procesorski plošči Pentium® (CPUe-1/2):

    Položaj mostičkov za delovanje v načinuLoLa na procesorski plošči PowerCPU:

Položaj mostička je enak na plošči PowerCPU in plošči PowerCPU EE. Na plošči PowerCPU EE kartico SD zamenja MSDB (Mass Storage Daughter Board – hčerinska plošča za množično shranjevanje) 8 GB kot naprava za množično shranjevanje. MSDB je opremljena s pomnilniškim čipom eMMC (embeded Multi-Media Card – vdelana kartica Multi-Media Card).

  4. Priključite ploščo v platformo.

  5. Zaženite strežniški program LoLa in z možnostjo Delivery Location (Mesto prenosa) poiščite paket programske opreme, ki ga želite prenesti.

  6. Izberite imenik, v katerem je imenik "DownloadingItems", in potrdite vnos. Okvir Location (Mesto) prikaže ime datoteke in pot do nje.

Od izdaje 8.1 morate uporabljati različico LoLa 400/7.1 ali novejšo. Ta različica omogoča izbiranje prenosa binarnih datotek 8082 My IC Phone. V sistemu LoLa ni posebne možnosti za izbiro modela 4135 IP Conference Phone. Privzeto se samodejno prenesejo binarne datoteke za model 4135 IP Conference Phone.

  7. Izberite polje ACD/MLAA/SCR service (Storitev ACD/MLAA/SCR), da prenesete izbirne komponente ACD (Automatic Call Distribution – Samodejno razdeljevanje klicev) in/ali MLAA (Multiple Automated Attendant – Več samodejnih telefonskih central) in/ali SCR (Smart Call Routing – Pametno usmerjanje klicev). Licenca določa, katere komponente bodo nameščene. Te so del istega paketa.

  8. Če je paket programske opreme veljaven, je omogočen gumb Next (Naprej).

  9. V oknu za izbiro države izberite jezikovni paket in licenco, ki ju želite namestiti.

  10. Kliknite Next (Naprej).

  11. Izberite vrsto namestitve.

  12. Kliknite Next (Naprej).

  13. Povežite procesor in osebni računalnik z ethernetnim kablom in vklopite procesor.

  14. Kliknite gumb Yes (Da).
    Po nekaj sekundah se samodejno zaženeta strežniška programa BOOTP in TFTP.

OPOMBA: Vrata Ethernet na računalniku morajo delovati, ko kliknete YES (DA), da se odpre pojavno okno "Is the dip switch on CPU OK (LoLa mode)?" (Je stikalo DIP na procesorju pravilno nastavljeno (način LoLa)?)

Ko se ta programa izvajata, LoLa zažene namestitveni strežnik.

Prenos

Ko je namestitveni strežnik zagnan, se poveže strežnik BOOTP, nato strežnik TFTP, čez nekaj časa pa še namestitveni strežnik LoLa (ki v okvirju Log (Dnevnik) za LoLa ustvari dnevniško datoteko). Poveže se plošča, nato pa se vpne njen bliskovni pomnilnik, kartica SD ali disk. Ko je postopek prenosa končan, se bliskovni pomnilnik, kartica SD ali disk izpne in povezava se prekine. Prenos programske opreme je uspešen.

Aktivacija

  1. Iztaknite ethernetni kabel iz posodobljene plošče, ploščo pa iz platforme.

  2. Premaknite stikalo DIP ali mostiček v prvotni položaj, kot je prikazano spodaj.

    Položaj stikala DIP za delovanje v standardnem načinu pri procesorju Aspen (CPU-1/2/3/4):

    Položaj stikala DIP za delovanje v standardnem načinu pri procesorju Pentium® (CPUe-1/2):

    Položaj mostička za delovanje v standardnem načinu pri procesorju PowerCPU:

    Položaj mostička je enak na plošči PowerCPU in plošči PowerCPU EE. Na plošči PowerCPU EE kartico SD zamenja MSDB (Mass Storage Daughter Board – hčerinska plošča za množično shranjevanje) 8 GB kot naprava za množično shranjevanje. MSDB je opremljena s pomnilniškim čipom eMMC (embeded Multi-Media Card – vdelana kartica Multi-Media Card).

  3. Ploščo še enkrat priključite na platformo in zaženite procesorsko ploščo.

Selitev (nadgradnja programske opreme)

Selitev na konfiguracijo z enim procesorjem

Če želite programsko opremo posodobiti z eno- ali večprocesorske konfiguracije na tako s samo enim procesorjem:

  1. Preverite IP naslove (za več informacij glejte razdelek Odpravljanje težav).

  2. Pri OMC varnostno kopirajte telefonske podatke.

  3. Nastavite stikalo DIP ali mostiček procesorja v položaj za način delovanja LoLa.

  4. Zaženite lola.exe.

  5. Izberite različico (R3.x ali novejšo) in jezik, ključ za programsko opremo in storitve.

  6. Kliknite Next (Naprej).

  7. Izberite možnost Migration mono CPU (Selitev na en procesor).

  8. Izberite prazen imenik, v katerega želite shraniti varnostno kopirane datoteke, ki jih želite obnoviti.

  9. Kliknite Next (Naprej).

  10. Priključite kabel procesorja na osebni računalnik.

  11. Zaženite procesor.

  12. Izberite gumb Yes (Da).

Po prvem koraku varnostnega kopiranja (glejte opombo) sta na voljo dve možnosti:

Možnost 1: Sprememba strojne opreme (procesor, trdi disk ...)

  1. Kliknite Next (Naprej).

  2. Nastavite stikalo DIP ali mostiček novega procesorja v položaj za način delovanja LoLa in zaženite procesor.

  3. KlikniteYes (Da).

Možnost 2: Ni spremembe strojne opreme

  1. Kliknite Next (Naprej).

  2. KlikniteYes (Da).

Ko je posodobitev programske opreme končana:

  1. Zaustavite procesor.

  2. Nastavite mostiček procesorja v položaj za standardni način delovanja.

  3. Zaženite procesor.

  4. Obnovite konfiguracijo z OMC.

Opomba: v primeru težav po varnostnem kopiranju uporabite možnost Install/Restore (Namestitev/obnova) v LoLa, da naložite R3.x (ali novejšo različico) s shranjenimi datotekami. Datoteke za obnovo so v imeniku, ki ste ga izbrali na začetku postopka.

Selitev na konfiguracijo z več procesorji

Ni podprta.

Namestitev/obnova

Če se pri posodobitvi programske opreme pojavi napaka, obnovite varnostno kopirane podatke z možnostjo za namestitev/obnovo v LoLa. Če se napaka pojavi pri namestitvi nove različice R3.x (ali novejše), je mogoča obnova podatkov strank:

  1. Preverite IP naslove (za več informacij glejte razdelek Odpravljanje težav).

  2. Z aženite lola.exe.

  3. Izberite različico R3.x (ali novejšo) in jezik, ključ za programsko opremo in storitve.

  4. Kliknite Next (Naprej).

  5. Izberite možnost Install/Restore (Namesti/obnovi).

  6. Izberitemesto, kamor naj bodo shranjene datoteke.

  7. Kliknite Next (Naprej).

  8. Priključite ethernetni kabel procesorja na osebni računalnik.

  9. Zaženite procesor.

  10. Kliknite gumb Yes (Da).

Ko je postopek namestitve/obnove končan:

  1. Zaustavite procesor.

  2. Nastavite stikalo DIP ali mostiček procesorja v položaj za standardni način delovanja.

  3. Zaženite procesor.

  4. Z OMC obnovite podatke.

Nasveti

Vedno uporabljajte ethernetne kable za hitre povezave, da se izognete težavam.

Programske opreme ne prenašajte v omrežnem okolju.

V nekaterih redkih primerih se lahko zgodi, da orodja, kot so protivirusni programi, upočasnijo omrežni dostop in s tem povzročijo napake zaradi poteka časovne omejitve. Če se vam to dogaja, med prenosom izklopite protivirusne programe.

Odpravljanje težav

Časovna omejitev

Za R1.1 in R2.x < R3.x ni sporočila o napaki vrste: mount Samba, bad Hardware ... (vpnite Sambo, napaka strojne opreme)
Program se ustavi in vas obvesti, da postopek ni uspel. Za več informacij s konzolo preverite sledi.

Ni zahteve

Če ni zahteve BOOTP in TFTP:

Preverite, ali je fizična povezava pravilno priključena z računalnika na OmniPCX Office.

Preverite, ali je stikalo DIP ali mostiček nastavljen na način delovanja LoLa.

Preverite IP naslove.

Težave, povezane z omrežnimi vmesniki

Če imate dva omrežna vmesnika ali spremenite IP naslov omrežnega vmesnika:

Preverite, ali je IP naslov, ki ga da DHCP BOOTP, pravilen.

Preverite, ali so IP naslovi pravilni:

  1. V registru pojdite na:
    HKEY_CURRENT_USER\Software\PCXTools\LoLa400_Rx.x\LoLa\Config

  2. IpAddress: vnesite IP naslov omrežnega vmesnika računalnika, priključenega na OmniPCX Office.

  3. COCPU_IP (konfiguracija z več procesorji): vnesite IP naslov omrežnega vmesnika računalnika +2 (npr. IpAddress = 172.25.52.36 , COCPU_IP = 172.25.52.38).

Kopiranje ni uspelo

Če je prikazano sporočilo o napaki: Copy Failed (Kopiranje ni uspelo)

  1. Preverite pravice za imenike.

  2. Preverite, ali je datoteka sploh v paketu.

Neskončen vnovični zagon

Če po namestitvi LoLa pride do neskončnega niza vnovičnih zagonov:

  1. Preverite, ali je bil v prvem čarovniku izbran jezik.

Napaka računa LoLa

Če je prikazano sporočilo o napaki: Failed LoLa Account (Napaka računa LoLa)

  1. Preverite pravilnik za gesla v sistemu Windows®.

  2. Če je treba, spremenite privzeto geslo računa LoLa v registru:

Za 32-bitne sisteme: HKEY_LOCAL_MACHINE\SOFTWARE\PCXTools\LoLa400_x.x\x.x\LolaPassword (pri čemer je x.x različica paketa LoLa)

Za 64-bitne sisteme: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PCXTools\LoLa400_x.x\x.x\LolaPassword (pri čemer je x.x različica paketa LoLa)

Ni dejavnosti v oknu

Ko kliknete Yes (Da) (strojna oprema je v redu), se lahko odpre okno s tem sporočilom:
Waiting for board download request.... (Čakanje na zahtevo plošče za prenos ...)
Če se po dveh minutah ne zgodi nič, omrežna povezava ne deluje.

Težava: ethernetna povezava ne deluje

Začnite postopek od začetka in z enim od teh postopkov preverite, ali fizična ethernetna povezava deluje:

Preden kliknete Yes (Da), zaženite procesor, počakajte nekaj sekund (8 do 10) in kliknite Yes (Da).

Preden kliknete Yes (Da), zaženite procesor in počakajte, da se v spodnjem desnem kotu sistemskega okna prikaže omrežna ikona.

Za ohranjanje omrežne povezave uporabite stikalo.