LoLa - Lokale PCX-lader

Alcatel-Lucent lokale downloadset voor PCX-software

Hulpprogramma voor het downloaden van de software Alcatel-Lucent OmniPCX Office Rich Communication Edition.

Vereisten

Pc met minimaal Pentium/AMD 233 MHz en RAM >= 256 MB

Microsoft Windows NT, Windows XP, Windows 2000, Windows 7 32/64 bits, Windows 8 32/64 bits (ondersteund vanaf Lola 400/9.1), Windows 8.1 32/64 bits (ondersteund vanaf Lola 400/12.1) of Windows 2012 Server 64 bits (ondersteund vanaf Lola 400/9.1)

Bij de netwerkeigenschappen moet "Bestands- en printerdeling voor Microsoft-netwerken" zijn geïnstalleerd en geselecteerd.

Internet Explorer >5.0 Service Pack 1

Ethernet-kaart geïnstalleerd

Ethernet-kabel voor snelle datacommunicatie: één 10BaseT twisted twisted-pair straight/crossoverkabel

Installatiemedia met de Alcatel-Lucent lokale downloadset voor PCX-software met de servertoepassingen LoLa, BOOTP en TFTP

Media met het softwarepakket dat naar de overeenkomstige kaart moet worden gedownload.

De map "DownloadingItems" van LoLa — het pad is bijvoorbeeld:
C:\Program Files\PCXTools\LoLa\LoLa400_Rx.x\DownloadingItems —
moet alle rechten toekennen aan de toepassing "LoLa400_Rx.x" en aan alle "gebruikers". Dit moet voor iedereen worden ingesteld op Lezen en Uitvoeren.

De map waarin het back-upbestand is opgeslagen (voor migratiedoeleinden bijv. update van de softwarerelease) moet voor iedereen worden ingesteld op Lezen en Uitvoeren.

De map tftpboot van LoLa — dit is de map waar LoLa is geïnstalleerd. Bijvoorbeeld:
C:\Program Files\PCXTools\lola\LoLa400_Rx.x\tftpboot —
moet voor iedereen worden ingesteld op Lezen en Uitvoeren.

Er moet meer vrije vasteschijfruimte zijn dan de ruimte die back-upbestanden innemen op de vaste schijf.

Er moeten geen andere versies van LoLa geïnstalleerd worden op de pc.

Als u gebruik maakt van UAC (User Account Control), moet u LOLA altijd draaien als Beheerder.

Installatie van LoLa

Voordat u LoLa installeert:

Controleer of het netwerk actief is (zie Probleemoplossing).

Verwijder alle vorige versies van LoLa.

OPMERKING: het is verplicht om v orige versies van LoLa te verwijderen voordat u de nieuwe versie installeert.

Allereerst installeert u op een van de volgende manieren de software vanaf de installatiemedia:

Start het zelfextraherende programma lola400_<versie>.exe (waarbij <versie> de versie van dit pakket aangeeft). Klik op de knop Unzip, en wijzig en bevestig de instellingen in het weergegeven venster Extractieprogramma. De procedure start na het uitpakken van het hoofdinstallatiebestand.

Wanneer een pakket al is uitgepakt, start u het programma setup.exe. Dit programma start de hoofdinstallatieprocedure.

De hoofdinstallatieprocedure is in drie stappen opgedeeld. Deze stappen zijn:

LoLa-installatie op de server

BOOTP-servertoepassing (installatie in stille modus)

TFTP-servertoepassing (installatie in stille modus)

LET OP: De drie hulpprogramma's zijn nodig voor het downloaden van de kaartsoftware, de software niet worden gedownload als een ervan ontbreekt.

Bij de installatie worden allereerst de systeemvereisten gecontroleerd. Er volgen twee bevestigingsverzoeken: bevestig de locaties voor het Installatiepad en de Programmamap. Na bevestiging worden de programmabestanden geïnstalleerd en het systeem bijgewerkt. Vervolgens worden achtereenvolgens de BOOTP- en de TFTP-server geïnstalleerd in de stille modus. Na voltooiing van de installatie kan LoLa automatisch worden gestart.

Configuratie

LoLa-server

Als er een firewall actief is op de pc, schakelt u deze uit.

Als u time-outs wilt verwijderen:

  1. Ga in het register naar ( x.x is het releasenummer):
    HKEY_CURRENT_USER\Software\PCXTools\LoLa400_Rx.x\LoLa\Config

  2. Stel UseTimeouts in op 0

Als u twee netwerkinterfaces gebruikt:

  1. Ga in het register naar:
    HKEY_CURRENT_USER\Software\PCXTools\LoLa400_Rx.x\LoLa\Config

  2. Ip-adres: geef het IP-adres op van de netwerkinterface in de pc die is aangesloten op OmniPCX Office.

  3. Voor een migratie met een CoCPU-configuratie: COCPU_IP: geef het IP-adres op van de netwerkinterface van de pc +2. Bijvoorbeeld:
    Ip-adres = 172.25.52.36, COCPU_IP = 172.25.52.38.

BOOTP-server

Geen configuratie nodig.

TFTP-server

Geen configuratie nodig.

Software downloaden

Procedure

Controleer of de software beschikbaar is die u wilt installeren, ofwel op de pc (op de vaste schijf of op cd-rom) of op het netwerk (houd er rekening mee dat een slechte netwerkverbinding het laden van de CPY negatief kan beïnvloeden).

  1. Schakel de processorkaart uit door op de kleine knop aan de voorzijde van de kaart te drukken.

  2. Wacht tot het processorlampje brandt (zonder te knipperen) en verwijder de kaart uit het PBX-rek.

  3. Maak de processorkaart los en zet de DIP-schakelaar of jumper op LoLa-bediening. U ziet hieronder deze stand aangegeven voor elk type processor.

    Stand voor de DIP-schakelaar voor LoLa-bediening op een Aspen processorkaart (CPU-1/2/3/4):

    Stand voor de DIP-schakelaar voor LoLa-bediening op een Pentium®-processorkaart (CPUe-1/2):

    Jumperstand voor LoLa-bediening op een PowerCPU-kaart:

De jumperstand de PowerCPU-kaart is gelijk aan de jumperstand voor de PowerCPU EE-kaart. Op de PowerCPU EE-kaart is de SD-kaart vervangen door een MSDB (Mass Storage Daughter Board) van 8 GB als uniek opslagmedium. MSDB is voorzien van een eMMC (embedded Multi-Media Card) geheugenchip.

  4. Plaats de kaart in het rek.

  5. Start de LoLa-servertoepassing en zoek via de optie Bronlocatie het softwarepakket dat u wilt downloaden

  6. Selecteer de map waaronder de map "DownloadingItems" staat en bevestig de selectie. In het deelvenster Locatie staat het pad met de bestandsnaam.

Vanaf release 8.1 moet LoLa 400/7.1 of een hogere versie worden gebruikt. Met deze versie kunnen de binaire indelingen van 8082 My IC Phone worden geselecteerd. LoLa bevat geen afzonderlijke optie voor selectie van de 4135 IP-conferentietelefoon. De binaire indelingen van de 4135 IP-conferentietelefoon worden standaard gedownload.

  7. Als u dit selectievakje ACD/MLAA/SCR service inschakelt, wordt de optionele component voor automatische oproepdistributie (ACD - Automated Call Distribution) en/of de MLAA gedownload. Welke onderdelen worden geïnstalleerd, wordt bepaald door de licentie. Ze zitten in hetzelfde pakket.

  8. De knop Volgende wordt actief wanneer het softwarepakket geldig is.

  9. In het venster Landselectie selecteert u het taalpakket en de licentie die u wilt installeren.

  10. Klik op de knop Volgende.

  11. Selecteer het type installatie.

  12. Klik op de knop Volgende.

  13. Sluit de Ethernet-crossoverkabel op de processor en de pc aan, en schakel de processor in.

  14. Klik op de knop Ja.
    Na een paar seconden worden de servertoepassingen BOOTP en TFTP automatisch gestart.

LET OP: De Ethernet-poort op de PC moet actief zijn als de melding "Staat de dipswitch op CPU in de juiste stand (LoLa-modus)?" met JA wordt bevestigd.

Zodra deze toepassingen actief zijn, start LoLa zijn installatieserver.

Downloaden

Na het starten van de installatieserver wordt de BOOTP-server aangesloten, vervolgens de TFTP-server en na een tijdje de LoLa-installatieserver. Deze laatste genereert een logboekbestand in het deelvenster Logboek van LoLa. De kaart wordt aangesloten, en daarna wordt het flash-geheugen, de SD-kaart of de schijf gemonteerd. Na voltooiing van de download wordt het flash-geheugen, de SD-kaart of de schijf weer losgekoppeld en de verbinding wordt verbroken. De softwaredownload is voltooid.

Activering

  1. Verwijder de Ethernet-kabel van de bijgewerkte kaart en haal de kaart uit het rek.

  2. Zet de DIP-schakelaar of jumper zoals hieronder geïllustreerd weer in zijn oorspronkelijke stand.

    Stand voor de DIP-schakelaar voor standaardbediening op een Aspen processorkaart (CPU-1/2/3/4):

    Stand voor de DIP-schakelaar voor standaardbediening op een Pentium®-processorkaart (CPUe-1/2):

    Jumperstand voor standaardbediening op een PowerCPU-kaart:

    De jumperstand de PowerCPU-kaart is gelijk aan de jumperstand voor de PowerCPU EE-kaart. Op de PowerCPU EE-kaart is de SD-kaart vervangen door een MSDB (Mass Storage Daughter Board) van 8 GB als uniek opslagmedium. MSDB is voorzien van een eMMC (embedded Multi-Media Card) geheugenchip.

  3. Plaats de kaart weer in het rek en start de processorkaart.

Migratie (Software-update)

Migratie naar een configuratie met één processor

Ga als volgt te werk als u de software wilt bijwerken van een configuratie met een of meerdere processors naar een configuratie met één processor:

  1. Controleer de IP-adressen (zie Probleemoplossing voor meer informatie).

  2. Maak met OMC een back-up van de telefoniegegevens.

  3. Zet de DIP-schakelaar of jumper voor de processor in de stand voor LoLa-bediening.

  4. Voer lola.exe uit.

  5. Selecteer het bronpakket (R3.x of hoger) en selecteer de taal, de softwaresleutel en de services.

  6. Klik op Volgende

  7. Selecteer de optie Migratie van éénn processor.

  8. Selecteer een lege map waarin u de back-upbestanden opslaat die hersteld moeten worden.

  9. Klik op Volgende

  10. Sluit de crossoverkabel op de processor en de pc aan.

  11. Start de processor.

  12. Selecteer de knop Ja.

Na een eerste back-upstap (zie opmerking) zijn er twee mogelijkheden:

Mogelijkheid 1: Hardware wijzigen (CPU, vaste schijf...)

  1. Klik op Volgende

  2. Zet de nieuwe jumper voor de processor in de stand voor LoLa-bediening, en start de processor.

  3. Klik op Ja

Mogelijkheid 2: geen hardwarewijziging

  1. Klik op Volgende

  2. Klik op Ja

Nadat het bijwerken van de software is voltooid:

  1. Schakel de processor uit.

  2. Zet de jumper voor de processor in de standaardpositie.

  3. Start de processor.

  4. Zet met OMC de configuratie weer terug.

N.B.: u kunt de opgeslagen bestanden in R3.x (of een latere versie) laden wanneer er een probleem optreedt nadat u de optie Installeren/terugzetten van LoLa hebt gebruikt. De terug te zetten bestanden staan in de map die u hiervoor eerder hebt geselecteerd.

Migratie naar een configuratie met meerdere processors

Niet ondersteund.

Installeren/terugzetten

Als er een fout optreedt tijdens de software-update, kunt u de LoLa-optie Installeren/terugzetten gebruiken om de back-upgegevens terug te zetten. Als de fout optreedt tijdens de installatie van de nieuwe R3.x-versie (of hogere versie), kunt u de klantgegevens terugzetten:

  1. Controleer de IP-adressen (zie Probleemoplossing voor meer informatie).

  2. V oer lola.exe uit.

  3. Selecteer het bronpakket (R3.x of hoger) en selecteer de taal, de softwaresleutel en de services.

  4. Klik op Volgende

  5. Selecteer de optie Installeren/terugzetten.

  6. Selecteerde locatie waar u de bestanden wilt opslaan.

  7. Klik op Volgende

  8. Sluit de Ethernet-kabel van de processor aan op de pc.

  9. Start de processor.

  10. Klik op de knop Ja.

U gaat als volgt verder nadat Installeren/terugzetten is voltooid:

  1. Schakel de processor uit.

  2. Zet de DIP-schakelaar of jumper voor de processor in de stand voor standaardbediening.

  3. Start de processor.

  4. Zet met OMC de gegevens weer terug.

Tips

Gebruik altijd Ethernet-kabels voor hoge snelheid om verbindingsproblemen te voorkomen.

Download software niet in een netwerkomgeving.

In uitzonderlijke gevallen kunnen programma's zoals antivirusprogramma's het netwerkverkeer vertragen zodat time-outfouten optreden. Als dit het geval is, schakelt u de antivirusprogramma's uit voor de duur van het downloaden.

Probleemoplossing

Time-out

Voor versie R1.1 en R2.x < R3.x,is er geen berichttype: Samba koppelen, hardwareprobleem ...
De toepassing stopt en meldt dat de bewerking is mislukt. U kunt met een traceconsole meer informatie verkrijgen.

Geen verzoek

Als er geen BOOTP- en TFTP-verzoeken zijn, doet u het volgende:

Controleer of de fysieke verbinding tussen de pc en OmniPCX Office goed werkt.

Controleer of de DIP-schakelaar of jumper in de stand LoLa-bediening staat.

Controleer de IP-adressen.

Problemen in verband met de netwerkinterfaces

Ga als volgt te werk als u twee netwerkinterfaces gebruikt of het IP-adres van de netwerkinterface wijzigt:

Controleer of het IP-adres dat door DHCP BOOTP juist is

Controleer of de IP-adressen juist zijn:

  1. Ga in het register naar:
    HKEY_CURRENT_USER\Software\PCXTools\LoLa400_Rx.x\LoLa\Config

  2. Ip-adres: geef het IP-adres op van de netwerkinterface in de pc die is aangesloten op OmniPCX Office.

  3. COCPU_IP (configuratie met meerdere processors): geef het IP-adres op van de netwerkinterface van de pc +2. Bijvoorbeeld: Ip-adres = 172.25.52.36 , COCPU_IP = 172.25.52.38).

Kopiëren is mislukt

Ga als volgt te werk als het foutbericht Kopiëren is mislukt verschijnt

  1. Controleer de toegangsrechten voor de mappen.

  2. Controleer of de bronlocatie het juiste bestand bevat.

Oneindig opnieuw opstarten

Als na installatie van LoLa het systeem telkens blijft opstarten:

  1. Controleer of de taal is geselecteerd in de eerste wizard.

Probleem met LoLa-account

Ga als volgt te werk als het foutbericht Probleem met LoLa-account

  1. Controleer het wachtwoordbeleid van Windows®.

  2. Pas zo nodig het standaardwachtwoord aan voor de LoLa-account in het register:

Op een 32-bits besturingssysteem: HKEY_LOCAL_MACHINE\SOFTWARE\PCXTools\LoLa400_x.x\x.x\LolaPassword (hierbij is x.x de LoLa-versie)

Op een 64-bits besturingssysteem: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PCXTools\LoLa400_x.x\x.x\LolaPassword (hierbij is x.x. de LoLa-versie)

Geen activiteit in venster

Nadat u op de knop Ja hebt geklikt (hardware is OK), wordt er een venster weergegeven met het bericht:
Er wordt gewacht op verzoek tot downloaden van kaart....
Als na een paar minuten (2 min.) nog niets is veranderd, is de netwerkverbinding niet beschikbaar.

Probleem: de Ethernet-verbinding is niet beschikbaar

Start de procedure overnieuw en controleer op een van de volgende manier of de fysieke Ethernet-verbinding beschikbaar is:

Start de processor alvorens op Ja te klikken, wacht een paar seconden (8 tot 10 seconden) en klik op Ja.

Start de processor alvorens op Ja te klikken, wacht tot rechtsonder in het systeemvenster het netwerkpictogram wordt weergegeven.

Gebruik een switch om de netwerkverbinding in stand te houden.