LoLa - Local PCX Loader (Cargador PCX local)

Kit Alcatel-Lucent para descargar localmente software PCX

Utilidad de descarga de software para Alcatel-Lucent OmniPCX Office Rich Communication Edition.

Requisitos

PC Pentium/AMD con 233 MHz y RAM >= 256 MB como mínimo

Microsoft Windows NT, Windows XP, Windows 2000, Windows 7 32/64 bits, Windows 8 32/64 bits (compatible a partir de Lola 400/9.1), Windows 8.1 32/64 bits (compatible a partir de Lola 400/12.1) o Windows 2012 Server 64 bits (compatible a partir de Lola 400/9.1)

En las propiedades de red deben estar instalados y seleccionados los "Archivos y la impresora para la red Microsoft"

Internet Explorer >5.0 Service Pack 1

Tarjeta Ethernet instalada

Cable Ethernet para comunicación de datos de alta velocidad: un cable recto/cruzado 10BaseT de pares trenzados

Soporte de instalación con el kit Alcatel-Lucent para descargar localmente el software PCX, que incluye LoLa y las aplicaciones de servidor BOOTP y TFTP

Soporte que incluye el paquete de software para descargar en la correspondiente tarjeta

El directorio "DownloadingItems" de LoLa — la ruta es, por ejemplo:
C:\Program Files\PCXTools\LoLa\LoLa400_Rx.x\DownloadingItems —
debe tener todos los derechos de la aplicación "LoLa400_Rx.x" y para todos los "usuarios". Debe tener permisos de lectura y ejecución para todos los usuarios

El directorio en el que se guardan los archivos de copia de seguridad (para realizar migraciones, es decir, actualizaciones de las versiones de software) debe tener permisos de lectura y ejecución para todos los usuarios

El directorio tftpboot de LoLa — la ruta en la que se ha instalado LoLa, por ejemplo:
C:\Program Files\PCXTools\lola\LoLa400_Rx.x\tftpboot —
debe tener permisos de lectura y ejecución para todos los usuarios

El espacio en disco libre debe ser superior al espacio en disco utilizado por los archivos de copia de seguridad

No debe haber ninguna otra versión de LoLa instalada en el PC

Con UAC (Control de cuentas de usuario), debe siempre ejecutar LOLA como administrador

Instalación de LoLa

Antes de instalar LoLa:

Compruebe que la red esté activa (consulte Resolución de problemas).

Desinstale cualquier versión anterior de LoLa.

NOTA: es obligatoriod esinstalar cualquier versión de LoLa antes de instalar la nueva versión.

El primer paso es instalar el software desde el soporte correspondiente de alguna de las siguientes maneras:

Al utilizar el programa de autodescompresión llamado lola400_<version>.exe (donde <version> se indica cuál es la versión del paquete). Personalice y confirme la configuración en la siguiente ventana del autodescompresor haciendo clic en Descomprimir. Tras descomprimir el archivo principal de instalación, se iniciará el proceso.

En caso de que el paquete ya esté descomprimido, lance el programa setup.exe, que inicia el proceso principal de instalación.

El proceso principal de instalación se divide en tres pasos, como sigue:

LoLa, servidor de instalación

BOOTP, aplicación de servidor (instalación en modo oculto)

TFTP, aplicación de servidor (instalación en modo oculto)

NOTA: estas tres herramientas son obligatorias para descargar el software de la tarjeta; si alguno de estos elementos no está presente, la descarga fallará.

La primera operación de la instalación es la verificación de los requisitos del sistema. A continuación se realizan dos peticiones de confirmación: confirmar la Ruta de instalación y las ubicaciones de la carpeta de programa. Después de confirmar estos datos, se instalan los archivos del programa y se actualiza el sistema. Seguidamente, se inicia la instalación en modo oculto primero de BOOTP y luego de TFTP. Una vez que la instalación ha finalizado, LoLa se puede iniciar automáticamente.

Configuración

Servidor LoLa

Si dispone de un cortafuegos en el PC, desactívelo.

Para eliminar los tiempos de espera:

  1. En el Registro, vaya a (x.x es el número de versión):
    HKEY_CURRENT_USER\Software\PCXTools\LoLa400_Rx.x\LoLa\Config

  2. Configure UseTimeouts a 0

Si utiliza dos interfaces de red:

  1. En el Registro, vaya a:
    HKEY_CURRENT_USER\Software\PCXTools\LoLa400_Rx.x\LoLa\Config

  2. IpAddress: introduzca la dirección IP de la interfaz de red del PC conectado a OmniPCX Office.

  3. En el caso de una migración desde una configuración con CoCPU: COCPU_IP: introduzca la dirección IP de la interfaz de red del PC +2, por ejemplo:
    IpAddress = 172.25.52.36, COCPU_IP = 172.25.52.38.

Servidor BOOTP

No requiere configuración.

Servidor TFTP

No requiere configuración.

Descarga del software

Procedimiento

Asegúrese de que el software que desea instalar está disponible, ya sea en el PC (en el disco duro o en un CD-ROM) o en red (tenga en cuenta que una red de mala calidad puede evitar que se cargue la CPU).

  1. Apague la tarjeta de la CPU pulsando el botón pequeño en la parte frontal de la tarjeta.

  2. Espere hasta que se encienda el LED de la CPU (sin parpadear) y retire la tarjeta de la plataforma PBX.

  3. Desconecte la tarjeta de CPU y, según el tipo de CPU, coloque el conmutador o jumper DIP en la posición de funcionamiento con LoLa como se muestra abajo.

    Posición del conmutador DIP para el funcionamiento con LoLa en una tarjeta de Aspen CPU (CPU-1/2/3/4):

    Posición del conmutador DIP para el funcionamiento con LoLa en una tarjeta de CPU Pentium® (CPUe-1/2):

    Posición del jumper para el funcionamiento con LoLa en una tarjeta PowerCPU:

La posición del jumper es la misma en la tarjeta PowerCPU y en la tarjeta PowerCPU EE. En la tarjeta PowerCPU EE, la tarjeta SD Card se sustituye por MSDB (tarjeta secundaria de almacenamiento masivo) de 8 GB como un dispositivo de almacenamiento masivo único. MSDB está equipado con un chip de memoria eMMC (tarjeta multimedia integrada).

  4. Conecte la tarjeta en la plataforma.

  5. Inicie la aplicación de servidor LoLa y utilice la opción Ubicación de archivos para localizar la ubicación del paquete de software de descarga.

  6. Seleccione el directorio que contiene el directorio "DownloadingItems" y confirme su elección. El cuadro Ubicación muestra el nombre del archivo, incluyendo la ruta.

A partir de la versión 8.1, debe usarse la versión LoLa 400/7.1 o superior. Esta versión le permite seleccionar la descarga de los binarios de 8082 My IC Phone. En LoLa, no hay una opción específica para seleccionar 4135 IP Conference Phone. De forma predeterminada, los binarios de 4135 IP Conference Phone se descargan de forma automática.

  7. Active la casilla Servicio ACD/MLAA/SCR para descargar los componentes opcionales ACD (Automatic Call Distribution) y/o MLAA (Multiple Automated Attendant) y/o SCR (Smart Call Routing). En la licencia se determinan los componentes que deben instalarse, ya que forman parte del mismo paquete.

  8. Si su paquete de software es válido, se activará el botón Siguiente.

  9. En la ventana de selección del país, seleccione el paquete de idioma y la licencia que va a instalar.

  10. Haga clic en el botón Siguiente.

  11. Seleccione el tipo de instalación

  12. Haga clic en el botón Siguiente.

  13. Conecte el cable Ethernet entre la CPU y el PC y encienda la CPU.

  14. Haga clic en el botón Sí.
    Tras unos segundos, se inician automáticamente las aplicaciones de servidor BOOTP y TFTP.

NOTA: el puerto de Ethernet en el PC debe estar funcionando al hacer clic en SÍ en el elemento emergente "¿El conmutador de la CPU está en la posición correcta (modo LoLa)?"

Una vez que estas aplicaciones se estén ejecutando, LoLa inicia su servidor de instalación.

Descarga

Tras iniciarse el servidor de instalación, se conecta el servidor BOOTP, después el servidor TFTP, y finalmente, pasado un tiempo, el servidor de instalación LoLa (que genera un archivo de registro en el cuadro de registro de LoLa). Se conecta la tarjeta y a continuación se monta su memoria flash, tarjeta SD o disco. Cuando finalizan las operaciones de descarga, se desmontan la memoria flash, la tarjeta SD o el disco y se cierra la conexión. La descarga de software termina correctamente.

Activación

  1. Desconecte el cable Ethernet de la tarjeta actualizada y desconecte la tarjeta de la plataforma.

  2. Coloque el conmutador o jumper DIP en su posición original, como se muestra a continuación.

    Posición del conmutador DIP para funcionamiento estándar en una tarjeta de CPU Aspen (CPU-1/2/3/4):

    Posición del conmutador DIP para funcionamiento estándar en una tarjeta de CPU Pentium® (CPUe-1/2):

    Posición del jumper para funcionamiento estándar en una tarjeta PowerCPU:

    La posición del jumper es la misma en la tarjeta PowerCPU y en la tarjeta PowerCPU EE. En la tarjeta PowerCPU EE, la tarjeta SD Card se sustituye por MSDB (tarjeta secundaria de almacenamiento masivo) de 8 GB como un dispositivo de almacenamiento masivo único. MSDB está equipado con un chip de memoria eMMC (tarjeta multimedia integrada).

  3. Conecte la tarjeta en la plataforma de nuevo e inicie la tarjeta de CPU.

Migración (actualización de software)

Migración a una configuración con una CPU

Para actualizar el software de una configuración con una o varias CPU a una configuración con una única CPU:

  1. Verifique la dirección IP (consulte Resolución de problemas si desea obtener más información)

  2. Con OMC, realice una copia de seguridad de los datos de telefonía

  3. Coloque el conmutador o jumper DIP de la CPU en la posición de funcionamiento con LoLa

  4. Ejecute el archivo lola.exe

  5. Seleccione la versión (R3.x o superior) y seleccione el idioma, la clave de software y los servicios

  6. Haga clic en Siguiente

  7. Seleccione la opción Migración a 1 CPU

  8. Seleccione un directorio vacío para guardar los archivos de copia de seguridad que va a restaurar

  9. Haga clic en Siguiente

  10. Conecte el cable de la CPU al PC

  11. Encienda la CPU

  12. Seleccione el botón Sí

Transcurrido un primer período del proceso de copia (véanse las Observaciones), pueden darse dos casos:

Caso 1: cambio de hardware (CPU, disco duro...)

  1. Haga clic en Siguiente

  2. Coloque el nuevo conmutador o jumper DIP de la CPU en la posición de funcionamiento con LoLa e inicie la CPU

  3. Haga clic en Sí

Caso 2: sin cambio de hardware

  1. Haga clic en Siguiente

  2. Haga clic en Sí

Cuando finalice la actualización de software:

  1. Apague la CPU

  2. Coloque el jumper de la CPU en la posición de funcionamiento estándar

  3. Encienda la CPU

  4. Con OMC, restaure la configuración

Observación:en caso de problemas tras la copia de seguridad, utilice la opción Instalar/restaurar de LoLa para cargar R3.x (o una versión posterior) con los archivos guardados. Los archivos que va a restaurar están ubicados en el directorio de almacenamiento que ha seleccionado anteriormente.

Migración a una configuración con varias CPU

No se admite.

Instalar/restaurar

Si se produce algún error durante la actualización de software, utilice la opción Instalar/restaurar de LoLa para restaurar los datos guardados en la copia de seguridad. Si se produce un error durante la instalación desde la nueva versión R3.x (o una versión superior), es posible restaurar posteriormente los datos del cliente:

  1. Verifique la dirección IP (consulte Resolución de problemas si desea obtener más información)

  2. E jecute lola.exe

  3. Seleccionela versión R3.x (o superior) y seleccione el idioma, la clave de software y los servicios

  4. Haga clic en Siguiente

  5. Seleccione la opción Instalar/restaurar

  6. Seleccionela ubicación de almacenamiento en la que deben guardarse los archivos

  7. Haga clic en Siguiente

  8. Conecte el cable Ethernet de la CPU al PC

  9. Encienda la CPU

  10. Haga clic en el botón Sí

Cuando concluya el proceso de Instalar/restaurar:

  1. Apague la CPU

  2. Coloque el conmutador o jumper DIP de la CPU en la posición de funcionamiento estándar

  3. Encienda la CPU

  4. Con OMC, restaure los datos

Recomendaciones

Utilice siempre cables Ethernet de alta velocidad para evitar problemas de conexión.

No descargue software en un entorno de red.

En contadas ocasiones, se ha observado que algunas herramientas, como los programas antivirus, pueden ralentizar el acceso a la red y provocar errores de tiempo de espera. Si se da este caso, desactive los programas antivirus durante el proceso de descarga.

Solución de problemas

Temporización

Para R1.1 y R2.x < R3.x,no hay mensajes de error del tipo: montaje Samba, Hardware defectuoso ...
La aplicación se detiene e informa de que la operación ha fallado. Si desea obtener más información, utilice una consola para verificar las trazas.

Ninguna solicitud

Si los servidores BOOTP y TFTP no hacen ninguna solicitud:

Compruebe que el enlace físico esté conectado correctamente desde el PC OmniPCX Office

Verifique que el conmutador o jumper DIP esté en la posición de funcionamiento con LoLa

Compruebe la dirección IP

Problemas relacionados con interfaces de red

Si tiene dos interfaces de red o ha cambiado la dirección IP de una de ellas:

Verifique que la dirección IP proporcionada por DHCP BOOTP sea correcta

Verifique que las direcciones IP sean correctas:

  1. En el Registro, vaya a:
    HKEY_CURRENT_USER\Software\PCXTools\LoLa400_Rx.x\LoLa\Config

  2. IpAddress: introduzca la dirección IP de la interfaz de red del PC conectado a OmniPCX Office.

  3. COCPU_IP (configuración con varias CPU): introduzca la dirección IP de la interfaz de red del PC +2 (por ejemplo: IpAddress = 172.25.52.36 , COCPU_IP = 172.25.52.38).

Fallo al copiar

Si le aparece el mensaje de error: Fallo al copiar

  1. Compruebe los permisos de los directorios

  2. Compruebe que el archivo existe en el directorio

Reinicio ilimitado

Tras la instalación de LoLa, si el reinicio se reproduce sin fin:

  1. Compruebe que el idioma está seleccionado en el primer asistente

Fallo en la cuenta LoLa

Si le aparece el mensaje de error: Fallo en la cuenta lola

  1. Compruebe la política de contraseñas de Windows®

  2. Si es necesario, modifique la contraseña por defecto de la cuenta LoLa en el registro:

En el sistema operativo de 32 bits: HKEY_LOCAL_MACHINE\SOFTWARE\PCXTools\LoLa400_x.x\x.x\LolaPassword (donde x.x es la versión LoLa)

En el sistema operativo de 64 bits: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PCXTools\LoLa400_x.x\x.x\LolaPassword (donde x.x es la versión LoLa)

No hay actividad en la ventana

Tras hacer clic en el botón Sí (el hardware está correcto), puede aparecer una ventana con el mensaje:
Esperando solicitud de descarga de placa....
Si transcurridos unos minutos (2 min) no sucede nada, significa que el enlace de red no está activo.

Problema: el enlace Ethernet no está activo

Inicie el procedimiento desde el principio y verifique que esté activo el enlace físico Ethernet de alguna de las siguientes formas:

Antes de hacer clic en el botón Sí, inicie la CPU, espere unos segundos (de 8 a 10) y haga clic en el botón Sí

Antes de hacer clic en el botón Sí, inicie la CPU, espere a que se muestre el icono de red en la parte inferior derecha de la ventana de Sistema

Utilice un conmutador para mantener el enlace de red